Author Topic: LCAC - "undefined" loans  (Read 15387 times)

Cries

  • Jr. Member
  • **
  • Posts: 91
    • View Profile
LCAC - "undefined" loans
« on: November 14, 2013, 10:14:10 AM »
Hey guys.

To anyone using LCAC's loan scanning function - are a significant portion of your loans coming up as "undefined"?

I just noticed this today when I scanned my loans.  Approx 50% of my loans are now showing "undefined" as their FICO, and the links to the loans on lendingclub's website are broken.

Is there a fix?  Did I break something?

Cries

  • Jr. Member
  • **
  • Posts: 91
    • View Profile
Re: LCAC - "undefined" loans
« Reply #1 on: November 14, 2013, 10:53:26 AM »
I updated to the latest LCAC version - problem continues!

yojoakak

  • Hero Member
  • *****
  • Posts: 763
    • View Profile
    • Check out my Greasemonkey/Tampermonkey script for LendingClub here
    • Email
Re: LCAC - "undefined" loans
« Reply #2 on: November 14, 2013, 11:35:50 AM »
I think LendingClub is throttling the number of Loan Performance pages one can look at over some period of time.

When I would click on of the error links to open the Loan Performance page, LendingClub would return with their Temporarily Unavailable" maintenance web page, although other pages would still work.

I thought I slowed down the scan below the limit, but it was just trial and error. (I am running a scan at the moment on my machine and it seems to be going OK.)

Can you open one of the links, and keep it open, then try loading it again after a few minutes? This would help to make sure the link is not malformed or something.

« Last Edit: November 14, 2013, 12:03:48 PM by yojoakak »

GS

  • Sr. Member
  • ****
  • Posts: 413
    • View Profile
Re: LCAC - "undefined" loans
« Reply #3 on: November 14, 2013, 12:10:01 PM »
I noticed the same thing.  It would scan about 30 then stop working.  I'd get an error message when I tried to open it manually.  Thanks for the update.

Cries

  • Jr. Member
  • **
  • Posts: 91
    • View Profile
Re: LCAC - "undefined" loans
« Reply #4 on: November 14, 2013, 12:37:26 PM »
The "temporarily unavailable" page on the LC website seems to be permanent.  It doesnt seem to fix itself after an hour. 

yojoakak

  • Hero Member
  • *****
  • Posts: 763
    • View Profile
    • Check out my Greasemonkey/Tampermonkey script for LendingClub here
    • Email
Re: LCAC - "undefined" loans
« Reply #5 on: November 14, 2013, 01:40:29 PM »
The "temporarily unavailable" page on the LC website seems to be permanent.  It doesnt seem to fix itself after an hour.

Could you send me the URL?

Cries

  • Jr. Member
  • **
  • Posts: 91
    • View Profile
Re: LCAC - "undefined" loans
« Reply #6 on: November 14, 2013, 01:50:52 PM »
Just one?  https://www.lendingclub.com/account/loanPerf.action?loan_id=7667614&order_id=12131930&note_id=31734449

or do you want me to copy/paste all of the broken hyperlinks?

Cries

  • Jr. Member
  • **
  • Posts: 91
    • View Profile
Re: LCAC - "undefined" loans
« Reply #7 on: November 14, 2013, 01:52:37 PM »
Actually, as I was clicking through them all, I noticed that some of them got fixed and some didnt. 

GS

  • Sr. Member
  • ****
  • Posts: 413
    • View Profile
Re: LCAC - "undefined" loans
« Reply #8 on: November 14, 2013, 02:23:10 PM »

Cries

  • Jr. Member
  • **
  • Posts: 91
    • View Profile
Re: LCAC - "undefined" loans
« Reply #9 on: November 14, 2013, 02:51:53 PM »
Can you recommend how I edit the code to slow the scan down even more? 


I think LendingClub is throttling the number of Loan Performance pages one can look at over some period of time.

When I would click on of the error links to open the Loan Performance page, LendingClub would return with their Temporarily Unavailable" maintenance web page, although other pages would still work.

I thought I slowed down the scan below the limit, but it was just trial and error. (I am running a scan at the moment on my machine and it seems to be going OK.)

Can you open one of the links, and keep it open, then try loading it again after a few minutes? This would help to make sure the link is not malformed or something.

yojoakak

  • Hero Member
  • *****
  • Posts: 763
    • View Profile
    • Check out my Greasemonkey/Tampermonkey script for LendingClub here
    • Email
Re: LCAC - "undefined" loans
« Reply #10 on: November 14, 2013, 03:58:52 PM »
Can you recommend how I edit the code to slow the scan down even more? 


Around line 9668 there is a line:

var delay = 200 + Math.random() * 200;


Change the first 200 to 500 or 1000 or more (it's in milliseconds).

« Last Edit: November 14, 2013, 04:01:21 PM by yojoakak »

Cries

  • Jr. Member
  • **
  • Posts: 91
    • View Profile
Re: LCAC - "undefined" loans
« Reply #11 on: November 14, 2013, 05:14:19 PM »
Awesome.  it seems to have fixed it.

yojoakak

  • Hero Member
  • *****
  • Posts: 763
    • View Profile
    • Check out my Greasemonkey/Tampermonkey script for LendingClub here
    • Email
Re: LCAC - "undefined" loans
« Reply #12 on: November 14, 2013, 05:25:45 PM »
Awesome.  it seems to have fixed it.

What value did you use? I will make it the default.

core

  • Hero Member
  • *****
  • Posts: 1790
  • Your loss is my gain
    • View Profile
Re: LCAC - "undefined" loans
« Reply #13 on: November 14, 2013, 06:10:25 PM »
So LC has definitely added some new throttling today?  It wasn't just temporary LC issues?   Strange that of all things, they don't want you looking at too many of your own loans.

yojoakak-  If you work out the exact timing restrictions they have in place (and if they're going to stay,) you may want to change it so the time is measured from start of fetch to next start of fetch rather than a fixed sleep time from end of one to start next.  On a poor connection like mine I could eat up the requisite time just waiting on one response.  Otherwise someone's luck with the default settings is going to depend on how fast things happen to go for them that day on that machine.

Cries

  • Jr. Member
  • **
  • Posts: 91
    • View Profile
Re: LCAC - "undefined" loans
« Reply #14 on: November 14, 2013, 08:35:12 PM »
Awesome.  it seems to have fixed it.

What value did you use? I will make it the default.
I used 2000ms at first, and it fixed some of it.  I now have it at 3000ms, but the problem isnt completely fixed. 

Im scanning like 2,000 loans.  Out of the 2,000 there are about 50 that intermittently pop up as undefined when I used 3,000ms.  I will try to bump it up more and see what happens - but its a really long wait to get the scan finished.