Author Topic: Was LoanBrowseLoans Broken This Morning?  (Read 5744 times)

Rob L

  • Hero Member
  • *****
  • Posts: 2133
    • View Profile
Was LoanBrowseLoans Broken This Morning?
« on: June 24, 2014, 09:50:44 AM »
With all the recent discussions regarding when loan new loan information becomes available I fired up SoapUI 5.0.0 a little before 6am PDT this morning.
It was working a few days ago so I don't think I've done anything wrong. Also GetSystemVersion and OrderGetPortfolios both work fine.
I attempted LoanBrowseLoans and SoapUI locked up. Waited for minutes and no response. I had to log out user (Linux / Ubuntu) just to kill it.
Still appears dead. Anyone else see same?

hoggy1

  • Sr. Member
  • ****
  • Posts: 401
    • View Profile
    • Email
Re: Was LoanBrowseLoans Broken This Morning?
« Reply #1 on: June 24, 2014, 05:46:42 PM »
Sorry, I don't know. But I tried soapUI last week and never could get the credentials in correctly to get anything to work. I got the methods imported OK but always got either no credentials or incorrect credentials errors in every case. soapUI is a large program and and mostly Greek to me.
Steve

Rob L

  • Hero Member
  • *****
  • Posts: 2133
    • View Profile
Re: Was LoanBrowseLoans Broken This Morning?
« Reply #2 on: June 24, 2014, 07:16:37 PM »
It's not that bad. You need to add a "Custom HTTP Header" (click on headers for any method, then the little +__  above the box to add).
The header name is: Authorization and the value is your API credential string (from the LC web site click settings at the top and use the API credentials string).
That's it. You have to add this for every method except  SystemGetVersion.
If you need more help PM me or post it here.

PS: Must have been broken this AM since it's working fine now.
« Last Edit: June 24, 2014, 07:19:45 PM by Rob L »

hoggy1

  • Sr. Member
  • ****
  • Posts: 401
    • View Profile
    • Email
Re: Was LoanBrowseLoans Broken This Morning?
« Reply #3 on: June 26, 2014, 02:08:11 PM »
Thanks Rob, I'll try again
Steve

johnh530

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: Was LoanBrowseLoans Broken This Morning?
« Reply #4 on: August 14, 2014, 09:58:25 PM »
It's not that bad. You need to add a "Custom HTTP Header" (click on headers for any method, then the little +__  above the box to add).
The header name is: Authorization and the value is your API credential string (from the LC web site click settings at the top and use the API credentials string).
That's it. You have to add this for every method except  SystemGetVersion.
If you need more help PM me or post it here.

PS: Must have been broken this AM since it's working fine now.

Thank you for posting this!

The API documentation omitted that you needed to send this header and how you could add the Authorization header.
I am still having issues with "Invalid  credentials. invalid authentication credentials", both on soapui and programmatically.  i can get SystemGetVersion both ways.  I've tried refreshing my api key.

It seems the key always ends with an equal(=).  It seems to fail both ways.

Any hints?

johnh...

kbenson99

  • Full Member
  • ***
  • Posts: 111
    • View Profile
    • Email
Re: Was LoanBrowseLoans Broken This Morning?
« Reply #5 on: August 14, 2014, 10:51:58 PM »
Programmatically, if your using Python, to add the authorization header (assuming that you are using the https://pypi.python.org/pypi/suds package) is as follows:

from suds.client import *
client = Client('https://api.lendingclub.com/ws/1.4?wsdl', headers={'Authorization': 'your api key'})
#to get the loans now simply call the appropriate soap method
loans = client.service.LoanBrowseLoans()

brycemason

  • Hero Member
  • *****
  • Posts: 801
    • View Profile
    • P2P-Picks.com
    • Email
Re: Was LoanBrowseLoans Broken This Morning?
« Reply #6 on: August 15, 2014, 01:34:10 AM »
I noticed the 10am load was like 2 seconds after the hour. I'm going to have to make an effort to observe what's going on this weekend and adjust things.

Fred

  • Hero Member
  • *****
  • Posts: 1421
    • View Profile
Re: Was LoanBrowseLoans Broken This Morning?
« Reply #7 on: August 15, 2014, 02:33:45 AM »
My log showed normal activities this morning.  Using the retail browsenotes link, I got the newly-fed loans at around 10:01:00:

2014-08-14 09:59:27,427 [LoanDataThread] INFO  https://resources.lendingclub.com/secure/primaryMarketNotes/browseNotes_1-RETAIL.csv in 0.21 seconds.
2014-08-14 09:59:27,849 [LoanDataThread] INFO  GetLoanDataThread - Iteration 1. Got 618 loans, delta=0% in 0.63 seconds.
...
2014-08-14 10:01:00,795 [LoanDataThread] INFO  https://resources.lendingclub.com/secure/primaryMarketNotes/browseNotes_1-RETAIL.csv in 0.04 seconds.
2014-08-14 10:01:01,307 [LoanDataThread] INFO  GetLoanDataThread - Iteration 9. Got 691 loans, delta=11.81% in 0.56 seconds.
« Last Edit: August 15, 2014, 02:36:34 AM by Fred »

Rob L

  • Hero Member
  • *****
  • Posts: 2133
    • View Profile
Re: Was LoanBrowseLoans Broken This Morning?
« Reply #8 on: August 15, 2014, 08:02:03 AM »
Nothing unusual seen here.
Yesterday all four browsenotes csv files with loan updates I saw were at 01:01 past the hour.

brycemason

  • Hero Member
  • *****
  • Posts: 801
    • View Profile
    • P2P-Picks.com
    • Email
Re: Was LoanBrowseLoans Broken This Morning?
« Reply #9 on: August 15, 2014, 03:09:02 PM »
I'm saying the web update was very quick. Not the CSV file.

Rob L

  • Hero Member
  • *****
  • Posts: 2133
    • View Profile
Re: Was LoanBrowseLoans Broken This Morning?
« Reply #10 on: August 15, 2014, 05:33:39 PM »
I haven't been looking manually and don't have any info on that one.
If correct and consistent this adds insult to injury to 3rd parties and other investors using automation.
Anyone who doesn't know what I mean see the Loan Information Asymmetrical Timing thread:
http://www.lendacademy.com/forum/index.php?topic=2376.0
Things may have just gotten much more difficult for automation.

Lovinglifestyle

  • Hero Member
  • *****
  • Posts: 902
    • View Profile
    • Email
Re: Was LoanBrowseLoans Broken This Morning?
« Reply #11 on: August 15, 2014, 09:00:59 PM »
I concur that the web update was faster at 10 and 2 today.  With my kind of filter click it was 8 sec. sooner (00:32 rather than 00:40) than I would have expected at 2/3 here, had I not been forewarned by the 10/11 update which surprised me sooner than that.

Randawl

  • Sr. Member
  • ****
  • Posts: 469
    • View Profile
Re: Was LoanBrowseLoans Broken This Morning?
« Reply #12 on: August 15, 2014, 11:12:58 PM »
Things may have just gotten much more difficult for automation.

And half of us rejoice and half of us lament.       ;)