Author Topic: Invalid API Response  (Read 4960 times)

compuatt

  • Newbie
  • *
  • Posts: 8
    • View Profile
    • Email
Invalid API Response
« on: March 09, 2016, 07:14:47 PM »
Running the latest version on PLS. 

When I run "browse notes" or when PLS runs automatically, the log shows "Invalid API Response."  No notes are purchased when PLS runs and when I "browse notes," PLS no longer lists available notes.  It just won't complete "browse notes."

I have uninstalled and reinstalled PLS.  I've rebooted.

Any ideas?

sociallender

  • Sr. Member
  • ****
  • Posts: 273
    • View Profile
    • Email
Re: Invalid API Response
« Reply #1 on: March 09, 2016, 08:24:33 PM »
Thanks for the heads up.  I am not sure what is going on.  It looks like LC API is not sending back a valid API response. I just ran a quick test of their API manually and the payload is empty:

[1] "{\"asOfDate\":\"2016-03-09T17:12:33.794-08:00\"}"
[1] "{\"asOfDate\":\"2016-03-09T17:12:34.898-08:00\"}"
[1] "{\"asOfDate\":\"2016-03-09T17:12:36.114-08:00\"}"
[1] "{\"asOfDate\":\"2016-03-09T17:12:36.832-08:00\"}"
[1] "{\"asOfDate\":\"2016-03-09T17:12:37.915-08:00\"}"
[1] "{\"asOfDate\":\"2016-03-09T17:12:38.874-08:00\"}"
[1] "{\"asOfDate\":\"2016-03-09T17:12:39.835-08:00\"}"
[1] "{\"asOfDate\":\"2016-03-09T17:12:40.873-08:00\"}"

Each of the above JSON API responses should have loan data included in the response.  PLS does basic data integrity checks to make sure the API response is valid.  Obviously, the response doesn't contain any loan data so it flags as an invalid response.  I am not sure when it started but hopefully LC resolves.  Unfortunately, I am traveling at the moment and can't have a deeper look.   

jheizer

  • Sr. Member
  • ****
  • Posts: 433
    • View Profile
    • LC Tools
Re: Invalid API Response
« Reply #2 on: March 09, 2016, 09:09:30 PM »
Just a heads up its not you.  Requests for new loans only is failing here as well via my application.
Replacement to P2P Quant's Percentile Tool http://lc.geekminute.com

sociallender

  • Sr. Member
  • ****
  • Posts: 273
    • View Profile
    • Email
Re: Invalid API Response
« Reply #3 on: March 09, 2016, 09:33:14 PM »
Thanks for sharing.  Hopefully LC fixes it soon :o

compuatt

  • Newbie
  • *
  • Posts: 8
    • View Profile
    • Email
Re: Invalid API Response
« Reply #4 on: March 09, 2016, 09:40:42 PM »
Thanks for the quick responses.  I'm rather technically capable so my brain was multitasking troubleshooting next steps in the background.  Now my brain can rest knowing the problem is not on my end. 

If misery loves company, I seem to have it with this issue.  ;)

compuatt

  • Newbie
  • *
  • Posts: 8
    • View Profile
    • Email
Is everyone down? (was Re: Invalid API Response)
« Reply #5 on: March 10, 2016, 10:03:32 AM »
Second day of "Invalid API Response" error messages. 

Is everyone using PLS down?  Anybody have any information on when the issue is expected to be fixed?

jheizer

  • Sr. Member
  • ****
  • Posts: 433
    • View Profile
    • LC Tools
Re: Invalid API Response
« Reply #6 on: March 10, 2016, 10:08:31 AM »
LC is working again.  I found 39 loans on the drop this morning.
Replacement to P2P Quant's Percentile Tool http://lc.geekminute.com

compuatt

  • Newbie
  • *
  • Posts: 8
    • View Profile
    • Email
Re: Invalid API Response
« Reply #7 on: March 10, 2016, 10:39:14 AM »
Thank you.  Will check tonight when I get home from work. 

compuatt

  • Newbie
  • *
  • Posts: 8
    • View Profile
    • Email
Re: Invalid API Response
« Reply #8 on: March 10, 2016, 01:08:14 PM »
It bought a note just now.  All good.   :)

Quackhead

  • Newbie
  • *
  • Posts: 18
    • View Profile
Re: Invalid API Response
« Reply #9 on: March 10, 2016, 09:55:03 PM »
I had this exact issue at 2pm and 6pm today. Hope lending club get this addressed... again.
Wonderful program BTW :)
« Last Edit: March 10, 2016, 09:57:36 PM by Quackhead »

Fred93

  • Hero Member
  • *****
  • Posts: 1898
    • View Profile
Re: Invalid API Response
« Reply #10 on: March 10, 2016, 11:26:39 PM »
I had this exact issue at 2pm and 6pm today. Hope lending club get this addressed... again.
Wonderful program BTW :)

Interesting.  Now we know it happens to different people at different times.  2&6 worked fine for me today, but screwed up yesterday.

JuP8

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: Invalid API Response
« Reply #11 on: March 11, 2016, 05:18:04 AM »
I'm having the same issue.

compuatt

  • Newbie
  • *
  • Posts: 8
    • View Profile
    • Email
Re: Invalid API Response
« Reply #12 on: March 11, 2016, 08:59:51 AM »
Still not working at of 9AM Friday. 

Anybody have any information on when a fix might be in place?

Rob L

  • Hero Member
  • *****
  • Posts: 1753
    • View Profile
Re: Invalid API Response
« Reply #13 on: March 11, 2016, 09:11:32 AM »
The 9am drop just now worked okay for me (not using PLS) but a roll-your-own.

Code: [Select]
2016-03-11 08:59:04 OK! Begin polling LC API for new loans release
2016-03-11 09:00:02 Ok_001!  New loans are available [299977 bytes retrieved] [375 loans] [306 loans delta]  [1.736 sec]

FWIW my download is csv formatted, not JSON.
I've had many "no loans found" occurrences at various drop times over the past week or two.

Quackhead

  • Newbie
  • *
  • Posts: 18
    • View Profile
Re: Invalid API Response
« Reply #14 on: March 12, 2016, 09:31:08 AM »
Seems ok the last few drops.