Author Topic: lendacademy web server problems  (Read 37307 times)

Fred93

  • Hero Member
  • *****
  • Posts: 2245
    • View Profile
lendacademy web server problems
« on: October 10, 2016, 04:52:44 PM »
Frequently over the past week, I get a 404 not found error message when attempting to view a page on the lendacademy forum.  Clicking refresh fetches the page (usually), but sometimes I have to wait a few minutes, after which a refresh will work.

Here's one of the messages...
<html>
<head><title>404 Not Found</title></head>
<body bgcolor="white">
<center><h1>404 Not Found</h1></center>
<hr><center>nginx</center>
</body>
</html>

Rob L

  • Hero Member
  • *****
  • Posts: 2133
    • View Profile
Re: lendacademy web server problems
« Reply #1 on: October 10, 2016, 06:33:37 PM »
Ditto

Lovinglifestyle

  • Hero Member
  • *****
  • Posts: 902
    • View Profile
    • Email
Re: lendacademy web server problems
« Reply #2 on: October 10, 2016, 07:50:38 PM »
Same here.

Fred93

  • Hero Member
  • *****
  • Posts: 2245
    • View Profile
Re: lendacademy web server problems
« Reply #3 on: October 17, 2016, 04:22:25 PM »
Getting worse I think.  The outages each last about 1 minute.  I see a few every day, but I'm not always using the web site, so I suspect there are dozens of them every day.

Zach

  • Administrator
  • Hero Member
  • *****
  • Posts: 622
    • View Profile
    • Email
Re: lendacademy web server problems
« Reply #4 on: October 17, 2016, 04:35:53 PM »
Thanks everyone for pointing this out. I will look into this further.

Rob L

  • Hero Member
  • *****
  • Posts: 2133
    • View Profile
Re: lendacademy web server problems
« Reply #5 on: October 17, 2016, 06:31:53 PM »
Yeah, there is something going on. Maybe a DoS attack  :)
But seriously, there are problems with the server I've not seen before.
Becoming a real PITA.

Fred93

  • Hero Member
  • *****
  • Posts: 2245
    • View Profile
Re: lendacademy web server problems
« Reply #6 on: October 18, 2016, 05:03:22 AM »
Some additional observations...

1. During one of these outages, I can ping the lendacademy web server. 

2. I have only noticed the outages while reading the forum, but during one of the outages I tried to access the main lendacademy web page.  It also timed out.  In other words, during the outage, all web pages are down, not just the forum.

3. The symptom is always a long delay (must be a timeout of some kind) followed by a 404 message from your server.  Because we get the 404 message, the browser is not timing out.  Something internal to the web server is timing out.

4. The 404 message we get is not your customized 404 message, but appears to be the default nginx 404 message.  I tried intentionally accessing a nonexistant page, something like www.lendacademy/forum/nonexistentpage.htm and that fails with a nice 404 message containing a lendacademy logo etc.

My guess is that your web server becomes unable to access the files that contain the web site content.  Perhaps a file system is going offline, or communication with a back-end server is being lost.

RyanL

  • Administrator
  • Newbie
  • *****
  • Posts: 27
    • View Profile
Re: lendacademy web server problems
« Reply #7 on: October 18, 2016, 07:33:58 AM »
Hi all, we've made some changes on the hosting side. If you continue to notice issues please let us know. Thanks!

rawraw

  • Hero Member
  • *****
  • Posts: 2795
    • View Profile
Re: lendacademy web server problems
« Reply #8 on: October 19, 2016, 03:54:42 AM »
It just happened to me.

Lovinglifestyle

  • Hero Member
  • *****
  • Posts: 902
    • View Profile
    • Email
Re: lendacademy web server problems
« Reply #9 on: October 19, 2016, 04:00:47 AM »
Ditto, 2 min. or so ago.  I copied my post before I lost it and started the process over.  Fine now.

Rob L

  • Hero Member
  • *****
  • Posts: 2133
    • View Profile
Re: lendacademy web server problems
« Reply #10 on: October 19, 2016, 10:48:15 AM »
Just happened to me again (twice in a row); the 404, nginx problem.

RyanL

  • Administrator
  • Newbie
  • *****
  • Posts: 27
    • View Profile
Re: lendacademy web server problems
« Reply #11 on: October 19, 2016, 01:18:04 PM »
Thanks for the heads up. We are continuing to work on this.

Fred93

  • Hero Member
  • *****
  • Posts: 2245
    • View Profile
Re: lendacademy web server problems
« Reply #12 on: October 20, 2016, 03:43:52 AM »
I observed one of these outages Thur morning 10/20 12:38AM PST (may have started earlier) to about 12:41:30AM.

This is the first time I've written down the times.  I watched it for over 3.5 minutes! 

RyanL

  • Administrator
  • Newbie
  • *****
  • Posts: 27
    • View Profile
Re: lendacademy web server problems
« Reply #13 on: October 20, 2016, 12:40:16 PM »
I observed one of these outages Thur morning 10/20 12:38AM PST (may have started earlier) to about 12:41:30AM.

This is the first time I've written down the times.  I watched it for over 3.5 minutes!

Thanks for documenting for us. I assume this is on forum pages? We made some more changes again today and we'll see if things improve.

Fred93

  • Hero Member
  • *****
  • Posts: 2245
    • View Profile
Re: lendacademy web server problems
« Reply #14 on: October 20, 2016, 09:54:42 PM »
I observed one of these outages Thur morning 10/20 12:38AM PST (may have started earlier) to about 12:41:30AM.

This is the first time I've written down the times.  I watched it for over 3.5 minutes!

Thanks for documenting for us. I assume this is on forum pages? We made some more changes again today and we'll see if things improve.

During the above mentioned outage, I only checked the forum.